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หัวข้อที่จะพูด

ความส าคัญของโมบายแอปพลิเคชัน
โมบายแอปพลิเคชันที่ใช้ในการเรียนรู้
แนวทางการพัฒนาโมบายแอปพลิเคชัน
สรุป
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คนจะเขา้ถึงอินเทอร์เน็ตผ่านโมบาย
มากกวา่ผ่านเดสก์ทอ๊ปภายใน 5 ปี



การใช้ iPhone และ iTouch ท าให้คน
เข้าถึงอินเทอร์เน็ตมากขึ้นอย่างรวดเร็ว



คนคาดหวังว่าจะเข้าถึงข้อมูลต่างๆ 
24x7 จากอุปกรณ์มอืถือ



ภาพรวมของโมบายอินเทอร์เน็ต

วงจรของยุคคอมพิวเตอรช์่วงนี้เป็นช่วงโมบายอินเทอร์เน็ต
โมบายอินเทอร์เน็ตเติบโตเร็วมาก
 3G + เว็บเครือข่ายสังคม + วิดีโอ + VoIP + อุปกรณ์โมบายที่ทันสมัย

แอปเปิลเป็นบริษัทที่เป็นผู้น าด้านความคิดสร้างสรรค์และมีอิทธิพลสูงใน
วงการอุปกรณ์โมบาย
 แต่ในระยะยาวจะต้องดูแอปพลิเคชัน ราคา และความน่าใช้ของอุปกรณ์

 เว็บเครือข่ายสังคมและโมบายมีผลกระทบกับรูปแบบการท าธุรกิจ
ข้อมูลโมบายเพิ่มขึ้นเป็นจ านวนมาก



วงจรยุคคอมพิวเตอร์



คุณสมบัติท่ีส าคัญของวงจรคอมพิวเตอร์ยุคโม
บายอินเทอร์เน็ต

ประมวลผลเร็วขึ้น + อินเทอร์เฟสติดต่อกับผู้ใช้ดีขึ้น + ราคาถูกลง + การบริการหลากหลาย



อินเตอร์เฟสและอุปกรณ์ที่เปลีย่นไปใน 30 ปี



ภาพรวมของโมบายอินเทอร์เน็ต

วงจรของยุคคอมพิวเตอร์ช่วงนี้เป็นช่วงโมบายอินเทอร์เน็ต
 โมบายอินเทอร์เน็ตเติบโตเร็วมาก
 3G + เว็บเครือข่ายสังคม + วิดีโอ + VoIP + อุปกรณ์โมบายที่ทันสมัย

แอปเปิลเป็นบริษัทที่เป็นผู้น าด้านความคิดสร้างสรรค์และมีอิทธิพลสูงใน
วงการอุปกรณ์โมบาย
 แต่ในระยะยาวจะต้องดูแอปพลิเคชัน ราคา และความน่าใช้ของอุปกรณ์

 เว็บเครือข่ายสังคมและโมบายมีผลกระทบกับรูปแบบการท าธุรกิจ
ข้อมูลโมบายเพิ่มขึ้นเป็นจ านวนมาก



การเติบโตของ 3G



ภาพรวมของการใช้ 3G ในส่วนต่างๆ ของโลก



สถิติของการใช้ 3G ในประเทศต่างๆ 



3G เป็นคีย์ในความส าเร็จของโมบายอินเทอร์เน็ต



สถิติการใช้เว็บเครือข่ายสังคมทั่วโลก



คนออนไลน์ใช้เฟซบุ๊กและยูทูบมากที่สุด 



ใช้เฟซบุ๊กทั้งในการสื่อสารและสร้างข้อมูลใหม่



การใช้เฟซบุ๊กในส่วนต่างๆของโลก



ประเทศทีม่ีจ านวนผู้ใช้เฟซบุ๊กมากท่ีสุด



ช่วงอายุของผู้ใช้เฟซบุ๊กในไทย



การเติบโตของผู้ใช้ในช่วงอายุต่างๆ



ข้อมูลโมบายส่วนใหญ่เปน็วิดีโอ



Skype ซึ่งให้บริการ VoIP มีจ านวนผู้ใช้มากกว่า Carrier ใดๆ 



Google Voice การบริการ VoIP ใหม่ที่ส าคัญ



ภาพรวมของโมบายอินเทอร์เน็ต

วงจรของยุคคอมพิวเตอร์ช่วงนี้เป็นช่วงโมบายอินเทอร์เน็ต
โมบายอินเทอร์เน็ตเติบโตเร็วมาก
 3G + เว็บเครือข่ายสังคม + วิดีโอ + VoIP + อุปกรณ์โมบายที่ทันสมัย

แอปเปิลเป็นบริษัทท่ีเป็นผู้น าด้านความคิดสร้างสรรค์และมีอิทธิพลสูงในว
โมบายอินเทอร์เน็ต
 แต่ในระยะยาวจะต้องดูแอปพลิเคชัน ราคา และความน่าใช้ของอุปกรณ์

 เว็บเครือข่ายสังคมและโมบายมีผลกระทบกับรูปแบบการท าธุรกิจ
ข้อมูลโมบายเพิ่มขึ้นเป็นจ านวนมาก



Apple iPhone + iTouch ประสบความส าเร็จมาก
อินเตอร์เฟสที่ใช้งานง่าย + เคร่ืองมือที่ใช้ในการพัฒนาสะดวก + ฮาร์ดแวร์ที่มีประสิทธิภาพ
+ ช่องทางการขายที่ดี + การเชื่อมต่อทางอินเทอร์เน็ตเยีย่ม (Wi-Fi + 3G)



การใช้โมบายอินเทอร์เนต็มีมากใน iPhone และ Android



การแบ่งสว่นตลาดของสมาร์ทโฟนในอเมริกา



ภาพรวมของโมบายอินเทอร์เน็ต

วงจรของยุคคอมพิวเตอร์ช่วงนี้เป็นช่วงโมบายอินเทอร์เน็ต
โมบายอินเทอร์เน็ตเติบโตเร็วมาก
 3G + เว็บเครือข่ายสังคม + วิดีโอ + VoIP + อุปกรณ์โมบายที่ทันสมัย

แอปเปิลเป็นบริษัทที่เป็นผู้น าด้านความคิดสร้างสรรค์และมีอิทธิพลสูงใน
วงการอุปกรณ์โมบาย
 แต่ในระยะยาวจะต้องดูแอปพลิเคชัน ราคา และความน่าใช้ของอุปกรณ์

 เว็บเครือข่ายสังคมและโมบายมีผลกระทบกับการสื่อสารกับการท าธุรกจิ
ข้อมูลโมบายเพิ่มขึ้นเป็นจ านวนมาก



สถิติของเฟซบุ๊กและไอโฟนไอทัชของแอปเปิล



สถิติของแอปพลเิคชันบนเฟซบุ๊ก
• มีจ านวนการดาวน์โหลดแอปพลิเคชันประมาณ 500 ล้านครั้ง
• มีจ านวนเฟซบุ๊กแอปพลิเคชันทัง้หมดประมาณ 500,000 



สถิติการใช้เฟซบุ๊กผ่านโมบาย

• มีจ านวนผู้ใช้เฟซบุ๊กประมาณ 150 ล้านคนที่ใช้เฟซบุ๊กผ่านอุป
กรณืโมบาย

• ผู้ใช้เฟซบุ๊กผ่านโมบายใช้เฟซบุ๊กด้วยความถี่มากกว่าผู้ใช้เฟซบุ๊กที่
ไม่ใช้ผ่านโมบายประมาณ 2 เท่า

• มีผู้ใช้บริการโมบายประมาณ 200 รายใน 60 ประเทศที่ส่งเสริม
การใช้เฟซบุ๊กโมบาย



สถิติของแอปพลเิคชันบนไอโฟน
• มีจ านวนการดาวน์โหลดแอปพลิเคชันประมาณ 4 พันล้านครั้ง
• โดยเฉลี่ยผู้ใช้ ไอโฟน/ไอทัชหนึ่งคนจะมีประมาณ 47 แอปพลิเคชัน



แอปพลิเคชันฟรีบนไอโฟนที่เป็นที่นิยม



อเมซอนพัฒนาการพาณิชย์อิเลก็ทรอนิกส์



โมบายพฒันาการพาณิชย์อิเลก็ทรอนิกส์



ตัวอย่างของ Location-based Services: ZipCar – บริษัทให้
เช่ารถที่ใช้โมบายอินเทอร์เน็ตและ GPS



ShopSavvy: สแกนบาร์โค้ดของสินค้าโดยใช้กล้อง
โทรศัพท์แล้วเปรียบเทียบราคา



การลดราคาที่จ ากัดเวลาในการขายสินค้าและจ ากัดผู้ที่
ได้รับการเชิญ



โมบายคปูอง



โมบายแอปพลิเคชันของแบรนด์ต่างๆ



การท าธุรกรรมแบบเรียลไทมผ์่านโมบาย



ภาพรวมของโมบายอินเทอร์เน็ต

วงจรของยุคคอมพิวเตอร์ช่วงนี้เป็นช่วงโมบายอินเทอร์เน็ต
โมบายอินเทอร์เน็ตเติบโตเร็วมาก
 3G + เว็บเครือข่ายสังคม + วิดีโอ + VoIP + อุปกรณ์โมบายที่ทันสมัย

แอปเปิลเป็นบริษัทที่เป็นผู้น าด้านความคิดสร้างสรรค์และมีอิทธิพลสูงใน
วงการอุปกรณ์โมบาย
 แต่ในระยะยาวจะต้องดูแอปพลิเคชัน ราคา และความน่าใช้ของอุปกรณ์

 เว็บเครือข่ายสังคมและโมบายมีผลกระทบกับการสื่อสารกับการท าธุรกิจ
ข้อมูลโมบายเพิ่มขึ้นเป็นจ านวนมาก



การใช้โมบายไม่ใช่เกี่ยวกับแค่เสียงแต่เกี่ยวกับข้อมูล



ผู้ใช้ไอโฟนใช้ข้อมูลหรืออินเทอร์เน็ตมากกว่า
ผู้ใช้โทรศพัท์ทั่วไป



การใชโ้มบายอินเทอร์เน็ตเพิม่การใช้งานเครือข่าย



หัวข้อที่จะพูด

ความส าคัญของโมบายแอปพลิเคชัน
โมบายแอปพลิเคชันที่ใช้ในการเรียนรู้
แนวทางการพัฒนาโมบายแอปพลิเคชัน
สรุป
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1) Open Culture: ดาวน์โหลดอีบุ๊กและวิดีโอ (ฟร)ี 



2)American Museum of Natural History: Cosmic 
Discoveries: การศึกษาเกี่ยวกบัจักรวาล(ฟร)ี

แสดงรูปภาพดาราศาสตร์ประมาณ 1000 รูป



3) NASA: ให้ข้อมูลเกี่ยวกับนาซ่า (ฟร)ี



4) Dictionary.com: ดิกชันนาร ี(ฟร)ี



5) The Chemical Touch: Lite Edition: ตารางธาตุเคมี (ฟรี)



6) Sign Language: ภาษามือ (ฟร)ี



7) Graph Calculator: เครื่องคิดเลขแบบกราฟิก 



8) Math Ref Free สูตรคณิตศาสตร์อ้างอิง (ฟร)ี



9) GMAT Practice: เตรียมสอบ GMAT (ฟร)ี



10) BrainPOP Featured Movie: เรียนรู้จากภาพยนตร์ (ฟรี)



1) National Geographic World Atlas: แผนที่โลก
โดยเนชัลแนลจีโอกราฟิก ($1.99) 



2) Star Walk (แผนที่ดาว) ($2.99)



3) Convert ~ the unit calculator: การแปลงหน่วย ($1.99) 



4) CliffNotes: เข้าใจวรรณกรรมในเวลาส้ันๆ ($1.99)



5) iStudiez Pro: ตารางเรียน การบ้านและตารางสอบ ($2.99)



หัวข้อที่จะพูด

ความส าคัญของโมบายแอปพลิเคชัน
โมบายแอปพลิเคชันที่ใช้ในการเรียนรู้
แนวทางการพัฒนาโมบายแอปพลิเคชัน
สรุป

63



การพฒันาโมบายแอปพลิเคชัน

• การพัฒนาโมบายแอปพลิเคชันส าหรับระบบอุปกรณ์ที่ใช้
ระบบปฏิบัติการ iOS (iPhone, iPad, และ iPod touch)

• การพัฒนาโมบายแอปพลิเคชันส าหรับอุปกรณ์ที่ใช้
ระบบปฏิบัติการ Android (ระบบปฎิบัติการแบบเปิด)



สิ่งที่จะต้องมีในการพัฒนา iOS แอปพลิเคชัน

• เครื่องคอมพิวเตอร์
• Mac OS X

• Apple Developer ID
• ลงทะเบียนสมัครได้ที่ http://developer.apple.com/programs/register/

• เครื่องมือที่ใช้ในการพัฒนา
• ดาวน์โหลดได้ที่ 

http://developer.apple.com/devcenter/ios/index.action

http://developer.apple.com/programs/register/
http://developer.apple.com/devcenter/ios/index.action


สิ่งที่จะต้องเรียนรู้ในการพัฒนา iOS แอปพลิเคชัน

• Cocoa Fundamentals Guide 
(http://developer.apple.com/library/ios/#documentation/Cocoa/Conceptu
al/CocoaFundamental)
• เพื่อที่จะเรียนรู้พื้นฐานภาษาโปรแกรม Objective-C, ข้อควรปฎิบัติและรูปแบบ

การออกแบบโดยใช้ UIKit, และระบบเฟรมเวิร์กอื่นๆ

• iOS Application Programming Guide
(http://developer.apple.com/library/ios/#documentation/iphone/conceptual/i

phoneosprogrammingguide/Introduction/Introduction.html)
• เพื่อที่จะออกแบบและพัฒนาแอปพลิเคชันบนอุปกรณ์อิเล็กทรอนิกส์ที่ใช้ iOS

http://developer.apple.com/library/ios/
http://developer.apple.com/library/ios/
http://developer.apple.com/library/ios/
http://developer.apple.com/library/ios/


ขั้นตอนที่ส าคัญในการพัฒนา iOS แอปพลิเคชัน

1. สร้างโปรเจกต์
2. ออกแบบอินเตอร์เฟสส่วนที่ติดต่อกับผู้ใช้งาน
3. เขียนโค้ด
4. สร้างและรนัแอปพลิเคชัน
5. ประเมินและปรับปรุงประสิทธิภาพของแอปพลิเคชัน



หน้าต่างของ Xcode โปรเจกต์



การเขียนโค้ดภาษา Objective-C



ตัวอย่างการพัฒนา iOS แอปพลิเคชัน Hello, World!

1. เริ่มการท างานของ Xcode แอปพลิเคชันโดยการไปคลิกเปิดแอปพลิเค
ชันที<่Xcode>/Applications
โดยที่ <Xcode> เป็นไดเรอทอเรีที่ติดตั้งเครื่องมือ Xcode

2. เลือก File > New Project
3. เลือกเทมเพล็ต Window-Based Application

เลือก iPhone ในเมนูป๊อปอัป



การสร้างโปรเจกต์ Xcodeใหม่



การเขียนโค้ดส าหรับ Hello, World!



การเขียนโค้ดในส่วนของวิว



การรันแอปพลิเคชัน



การพฒันาโมบายแอปพลิเคชัน

• การพัฒนาโมบายแอปพลิเคชันส าหรับระบบอุปกรณ์ที่ใช้
ระบบปฏิบัติการ iOS (iPhone, iPad, และ iPod touch)

• การพัฒนาโมบายแอปพลิเคชันส าหรับอุปกรณ์ที่ใช้
ระบบปฏิบัติการ Android (ระบบปฎิบัติการแบบเปิด)



สิ่งที่จะต้องมีในการพัฒนา Android แอปพลิเคชัน

• เครื่องคอมพิวเตอร์
• Mac OS X, Windows, หรือ Linux

• เครื่องมือสภาพแวดล้อมในการพัฒนา (IDE)
• Eclipse 3.4 (Ganymede) or 3.5 (Galileo)

• Eclipse JDT plugin (included in most Eclipse IDE packages)
• ถ้ายังไม่มี Eclipse ให้ดาวน์โหลดจาก http://www.eclipse.org/downloads/
• JDK 5 or JDK 6 (ไม่สามารถมีแค่ JRE เท่าน้ัน)

• เครื่องมือการพัฒนาแอนดรอยด์ปลั๊กอิน 

http://www.eclipse.org/downloads/


สิ่งที่จะต้องเรียนรู้ในการพัฒนา Android แอปพลิเคชัน

 ทักษะการพัฒนาโปรแกรมภาษาจาวา (จ าเป็นต้องม)ี
 ความรู้ความเข้าใจในภาษาเอกซ์เอ็มแอล 

(เป็นประโยชน์)
 ทักษะในการพฒันาโปรแกรมบน Android
ศึกษาได้ที่ 

http://developer.android.com/guide/index.html

http://developer.android.com/guide/index.html


ขั้นตอนที่ส าคัญในการพัฒนา Android แอปพลิเคชัน

1. สร้างโปรเจกต์
2. เขียนโค้ดจาวาและเขียนไฟล์ XML

• ไฟล์ XML ที่ใช้คือ 1) AndroidManifest.xml ซึ่งมีเพื่อประกาศคอมโพเนนต์หรือ
ส่วนประกอบต่างๆ ของแอปพลิเคชัน 2) ไฟล์ที่บันทึกไว้ในไดเรกทอรี res/layout/ 
เพื่อประกาศ layout ของแอปพลิเคชัน 3) ไฟล์ที่บันทึกไว้ในไดเรกทอรี res/menu/ 
เพื่อประกาศเมนูของแอปพลิเคชัน 4) ไฟล์ที่บันทึกไว้ในไดเรกอทรี res/values/ เพื่อ
เก็บค่าต่างๆ ของแอปพลิเคชัน

3. รันแอปพลิเคชัน
• หากใช้ Android Emulator จะต้องสร้าง Android Virtual Device (AVD)



เริ่มต้นติดตั้งเครื่องมอืในการพฒันา

1. ตรวจสอบว่าเครื่องคอมพิวเตอร์มี JDK เวอร์ชัน 5.0 ขึ้นไปและมี Eclipse 
3.4 ขึ้นไปหรือไม่

• ถ้าไม่มีให้ดาวน์โหลด JDK ที่ 
http://www.oracle.com/technetwork/java/javase/downloads/index.html และ 
Eclipse ที่ http://www.eclipse.org/downloads/

2. ดาวน์โหลดและติดตั้ง SDK
3. ติดตั้ง ADT Plugin ส าหรับ Eclipse
4. เพิ่ม Android 1.6 หรือ Android 2.2 เข้าไปใน SDK 

http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.eclipse.org/downloads/


การดาวน์โหลดAndroid SDK



การติดตัง้ Android SDK 

• แตกไฟล์ *.tgz  โดยใช้ค าสั่ง tar zxvf

• เพิ่มค าสั่งนี้ลงในไฟล์ .bashrc เพื่อเพิ่มไดเรอทอรี tools ของ <android 
SDK> ซึ่งจะท าให้สามารถรันค าสั่งจากที่ไหนก็ได้

export PATH=${PATH}:<your_sdk_dir>/tools



การดาวน์โหลด ADT Plugin for Eclipse (1/2)

• เปิด Eclipse, แล้วเลือก Help > Install New Software.
• ใน Available Software dialog, คลกิ Add....
• ใน Add Site dialog, ในช่อง “Name”, กรอกชื่อ, "Android 
Plugin” ในช่อง "Location" field, กรอก URL:
https://dl-ssl.google.com/android/eclipse/

• คลิก OK



ผลของการเพิ่ม Site ใน Eclipse 



การดาวน์โหลด ADT Plugin for Eclipse (2/2)

• ในวิว Available Software view, ถ้าหากเลอืกท างานกับ https://dl-
ssl.google.com/android/eclipse/
คลิกเลือก  "Developer Tools" 

• ซึ่งจะท าให้ Android DDMS and Android Development Tools ถกูเลือกโดย
อัตโนมัติ

• คลิก accept the license agreement and install any dependencies
• คลิก Finish



Android Developer Tools



การติดตัง้ ADT Plugin for Eclipse

• เลือก Window > Preferences
• เลือก Android ในช่องทางด้านซ้ายมือ
• กรอกที่อยู่ของ SDK
• คลิก Apply แล้วคลิก OK



สร้าง AVD เพื่อจะรัน Android Emulator

1.      ใน Eclipse, เลือก Window > Android SDK and AVD Manager.
2.     เลือก Virtual Devices ในช่องด้านซ้ายมือ
3. คลิก New
4. ใน Create New AVD dialog ที่ปรากฎข้ึนมา พิมพ์ชื่อของ AVD เช่น 

"my_avd“
5. เลือก Target  หากไม่มีข้อมูลให้เลือก ให้คลิกเมนู Available Packages 

เพื่อติดตั้งแพ็คเกจก่อน
4. คลิก Create AVD



การสร้าง AVD



ตัวอย่างการพัฒนา Android แอปพลิเคชัน Hello, World!

1. สร้างโปรเจกต์ใหม่
• ใน Eclipse, เลือก File > New > Project.

• เลือก "Android Project" แล้วคลกิ Next
• กรอกรายละเอียดของโปรเจกต์

• Project name: HelloAndroid
• Application name: Hello, Android
• Package name: com.example.helloandroid (or your own private namespace)
• Create Activity: HelloAndroid

• คลิก Finish



การสร้าง Android โปรเจกต์ใหม่



โค้ด HelloAndroid.java



ทดสอบแอปพลเิคชัน Hello, Android

คลิกเมนู Run > Run



สรุป

 ประชากรโลกจะใช้อุปกรณ์โมบายโดยเฉพาะสมาร์ทโฟนในการ
เข้าถึงอินเทอร์เน็ตมากขึ้น

 โมบายแอปพลิเคชันหลายอย่างน่าใช้และมีประโยชน์ในการเรียนรู้
 ควรมีการส่งเสริมและสนับสนุนการใช้โมบายแอปพลิเคชันเพื่อ

ประโยชน์เชิงสร้างสรรค์
 ควรมีการส่งเสริมและสนับสนุนให้คนไทยสามารถพัฒนาโมบาย

แอปพลิเคชันมากข้ึน



ข้อมูลอ้างอิง

• http://www.morganstanley.com/institutio

nal/techresearch/pdfs/MS_Internet_Tren

ds_060710.pdf

• http://www.facebakers.com

• http://www.facebook.com/press/info.php

?statistics

• http://www.openculture.com/2009/02/the

_top_educational_iphone_apps.html
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ข้อมูลอ้างอิง

• http://www.walyou.com/blog/2010/07/27/f

ree-iphone-apps-for-students/

• http://www.apple.com/iphone/apps-for-

everything/students.html

• http://developer.apple.com/library/io

• http://developer.android.com/resources/i

ndex.html
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ขอขอบคุณ

http://twitter.com/krunapon

http://www.slideshare.net/krunapon

http://gear.kku.ac.th/~krunapon

krunapon@kku.ac.th
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